Skip to content

Goorkey's Blog

Note the life of a Son of Karo highland

Uh hari ini ngantuk sekali, gak ada kerjaan lagi, luntang lantung mo ke kucingan kok panas so dari tadi cuman minum air putih aja. Sambil browsing internet, eh ada chating yang masuk dari teman kantor, dia komplen jika internet aksesnya lambat padahal yang diakses web servernya ada di lokasi Indonesia alias lokal, wedeuh! Maka jadi punya ide untuk coba buat dan pratek-kan hasil sertifikasi Mikrotik-ku, ku mo coba memisahkan bandwidth lokal dan international (OpenIXP dan IIX) kali-kali bisa membantu memecahkan masalah dari teman kantorku tadi.

Ok, langkah pertama minum air putih yang banyak, karena biasanya jika sudah main komputer jadi lupa segalanya, siapin laptop kesayanganku dan pc lainnya sehingga bisa kerja dengan 2 pc sekaligus. Untuk yang laptop ku pake ngerjain mikrotik melalui winbox, sedang yang pc ku pake u/ trial dan monitoring perubahan yang terjadi. Nah ini hasil perubahannya pada mikrotikku yang sudah ku upgrade ke versi 3.13.

Langkah 2.

daftar interface di pc routerku

0  R  name=”public” mtu=1500 type=”ether”

1  R  name=”local” mtu=1500 type=”ether”

daftar IP Addressku

0   address=202.169.224.101/27 network=202.169.224.96 broadcast=202.169.224.127 interface=public actual-interface=public

1   address=192.168.13.1/24 network=192.168.13.0 broadcast=192.168.13.255 interface=local actual-interface=local

Ip Routeku

0 A S  dst-address=0.0.0.0/0 gateway=202.169.224.97 interface=public gateway-state=reachable distance=1 scope=255 target-scope=10

1 ADC  dst-address=192.168.13.0/24 pref-src=192.168.13.1 interface=local distance=0 scope=10

2 ADC  dst-address=202.169.224.96/27 pref-src=202.169.224.101 interface=public distance=0 scope=10

Ip Firewall Nat

0   ;;; Masquerade-lan

chain=srcnat action=masquerade src-address=192.168.13.0/24 out-interface=public

1   ;;; web-proxy

chain=dstnat action=redirect to-ports=8080 src-address=192.168.13.0/24 in-interface=local dst-port=80 protocol=tcp

jangan lupa aktifkan web proxynya

set enabled=yes
set src-address=0.0.0.0
set port=3128
set hostname=”proxy.Agi.Net”
set transparent-proxy=yes
set parent-proxy=0.0.0.0:0
set cache-administrator=”support@sumaterautara.com”
set max-object-size=135698KiB
set cache-drive=system
set cache-on-disk: yes
set max-cache-size=unlimited
set max-ram-cache-size=unlimited
set max-fresh-time: 3d
set cache-hit-dscp: 4

/ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=3128
/ip firewall nat add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=3128
/ip firewall nat add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=3128

Import file nice.rsc ke mesin mikrotik dengan cara:

1. upload file nice.rsc yang bisa anda dapatkan di http://www.mikrotik.co.id/getfile.php?nf=nice.rsc ke mesin router anda

2. dari New Terminal, lakukan importing file nice.rsc anda, setelah selasai masuk ke langkah seting ip firewall mangle

4   ;;; nice-iix-intl

chain=prerouting action=mark-connection new-connection-mark=conn-iix passthrough=yes dst-address-list=nice in-interface=local

5   chain=prerouting action=mark-packet new-packet-mark=packet-iix passthrough=no connection-mark=conn-iix

6   chain=output action=mark-packet new-packet-mark=packet-iix passthrough=no connection-mark=conn-iix

7   chain=prerouting action=mark-packet new-packet-mark=packet-intl passthrough=no

8   chain=output action=mark-packet new-packet-mark=packet-intl passthrough=no

Kemudian buat simple queue:
0    name=”client-iix” target-addresses=192.168.13.0/24 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=packet-iix direction=both priority=8 queue=default-small/default-small limit-at=0/0 max-limit=64000/384000 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small

1    name=”client-intl” target-addresses=192.168.13.0/24 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=packet-intl direction=both priority=8 queue=default-small/default-small limit-at=0/0  max-limit=32000/256000 burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
selesai dah, coba anda cek/test, apakah ada perubahan pada counter mangle? Coba test juga u/ browsing ke situs lokal dan international

%d bloggers like this: